Adobe Video and Audio Apps: Upcoming Changes to OS Support

Ensuring optimal performance for future releases.

Featured in News
Adobe Video and Audio Apps: Upcoming Changes to OS Support

We want to give you advance notice that upcoming versions of the Adobe video and audio tools will require Windows 10 (version version 1703, or higher) or macOS 10.12 (or higher) to run. This applies to the next major releases of Adobe Media Encoder, After Effects, Audition, Character Animator, Prelude, and Premiere Pro.

Performance and stability are top priorities for all of our users. Running our apps on current versions of the Mac and Windows operating systems helps provide an optimal experience with our tools.

Background

We focus our development on currently supported OS versions and transition away from older versions as these are retired. We’re letting you know about these changes before they come into effect so you can plan ahead for any updates to legacy systems.

Microsoft discontinued mainstream support for Windows 8.1 in January 2018. Mainstream support for Windows 7 support ended in 2015. For more information on Windows support, visit the Windows lifecycle fact sheet.

Apple has announced macOS 10.14 (Mojave) for the fall of 2018 — and we will continue our policy of supporting the three most recent versions of MacOS.

Running Adobe tools on older operating systems

You can continue to run (or install) current or previous versions of the Adobe video and audio apps on older Mac and Windows operating systems. As noted, to run the next releases of the Adobe video and audio tools, you will need current versions of Windows and macOS.

Ensuring peak performance

Technology is always evolving, and we are making sure your tools evolve alongside the major operating systems and available hardware. Besides keeping your OS up to date, performance for video applications is impacted by your processor, available memory, storage, and GPU.

For more information visit the Premiere Pro System Requirements page. For more detailed information about operating system requirements for the next major release of Creative Cloud, see this post.

Recommended Articles